summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-09-10 15:19:55 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-09-10 15:19:55 (GMT)
commitcd8dc094f8a28afcde2959dfe8e7d205a93e4d6c (patch)
tree6573a20fa80fa829a7f053dea6754dda8942d230 /CMakeLists.txt
parent0e67feb17aba65d3359d81ed26d595c033e23a48 (diff)
downloadCMake-cd8dc094f8a28afcde2959dfe8e7d205a93e4d6c.zip
CMake-cd8dc094f8a28afcde2959dfe8e7d205a93e4d6c.tar.gz
CMake-cd8dc094f8a28afcde2959dfe8e7d205a93e4d6c.tar.bz2
ENH: Add warning messages if curses library is not found
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f049460..66556a4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,6 +72,8 @@ IF (UNIX)
INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
IF (CURSES_LIBRARY)
SUBDIRS(Source/CursesDialog/form)
+ ELSE (CURSES_LIBRARY)
+ MESSAGE("Curses libraries were not found. Curses GUI for CMake will not be build.")
ENDIF (CURSES_LIBRARY)
ENDIF (UNIX)