summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2006-10-13 14:52:34 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2006-10-13 14:52:34 (GMT)
commit72b38e3aa7ba5fa4a70144e05de36bc99fda173a (patch)
tree744005aab47678a2a742267a01799a8f53dd0cf7 /CMakeLists.txt
parent8883613cc022d0ae2c96d84adf79dd82b74df658 (diff)
downloadCMake-72b38e3aa7ba5fa4a70144e05de36bc99fda173a.zip
CMake-72b38e3aa7ba5fa4a70144e05de36bc99fda173a.tar.gz
CMake-72b38e3aa7ba5fa4a70144e05de36bc99fda173a.tar.bz2
ENH: merge changes from the main tree to the 2.4 branch
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 9 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4eb3d5b..9e913ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,9 +15,9 @@ SET(BUILD_SHARED_LIBS OFF)
# install tree.
SET(CMAKE_SKIP_RPATH ON CACHE INTERNAL "CMake does not need RPATHs.")
-SET(CMAKE_DATA_DIR "/share/CMake" CACHE STRING
+SET(CMAKE_DATA_DIR "/share/cmake-${CMake_VERSION}" CACHE STRING
"Install location for data (relative to prefix).")
-SET(CMAKE_DOC_DIR "/doc/CMake" CACHE STRING
+SET(CMAKE_DOC_DIR "/doc/cmake-${CMake_VERSION}" CACHE STRING
"Install location for documentation (relative to prefix).")
SET(CMAKE_MAN_DIR "/man" CACHE STRING
"Install location for man pages (relative to prefix).")
@@ -88,12 +88,18 @@ SET(CMAKE_CURL_INCLUDES "${CMAKE_CURRENT_SOURCE_DIR}/Utilities")
SET(CMAKE_CURL_LIBRARIES "cmcurl")
#-----------------------------------------------------------------------------
-# Build Curl library for CTest.
+# Build Tar library for CTest.
SUBDIRS(Utilities/cmtar)
SET(CMAKE_TAR_INCLUDES "${CMAKE_CURRENT_BINARY_DIR}/Utilities/cmtar")
SET(CMAKE_TAR_LIBRARIES "cmtar")
#-----------------------------------------------------------------------------
+# Build Compress library for CTest.
+SUBDIRS(Utilities/cmcompress)
+SET(CMAKE_COMPRESS_INCLUDES "${CMAKE_CURRENT_BINARY_DIR}/Utilities/cmcompress")
+SET(CMAKE_COMPRESS_LIBRARIES "cmcompress")
+
+#-----------------------------------------------------------------------------
# Build expat library for CMake and CTest.
SUBDIRS(Utilities/cmexpat)
SET(CMAKE_EXPAT_INCLUDES