summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2006-03-01 18:15:44 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2006-03-01 18:15:44 (GMT)
commit4077d6d80cb446f5c4e3c8739ae05375c6e62540 (patch)
tree522884603c3414e87154929ffee3c23eb870dcee /CMakeLists.txt
parentff50bb9f77199a14735a6a4778f667ecf153c7af (diff)
downloadCMake-4077d6d80cb446f5c4e3c8739ae05375c6e62540.zip
CMake-4077d6d80cb446f5c4e3c8739ae05375c6e62540.tar.gz
CMake-4077d6d80cb446f5c4e3c8739ae05375c6e62540.tar.bz2
ENH: Install system libraries only if project requires them
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cb22951..29afb11 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -224,6 +224,9 @@ INCLUDE (${CMake_SOURCE_DIR}/Utilities/Release/Release.cmake)
# If the cmake version includes cpack, use it
IF(EXISTS "${CMAKE_ROOT}/Modules/CPack.cmake")
+ IF(EXISTS "${CMAKE_ROOT}/Modules/InstallRequiredSystemLibraries.cmake")
+ INCLUDE(InstallRequiredSystemLibraries)
+ ENDIF(EXISTS "${CMAKE_ROOT}/Modules/InstallRequiredSystemLibraries.cmake")
SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "CMake is a build tool")
SET(CPACK_PACKAGE_VENDOR "Kitware")
SET(CPACK_PACKAGE_DESCRIPTION_FILE "${CMAKE_CURRENT_SOURCE_DIR}/Copyright.txt")