summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-09-28 15:36:54 (GMT)
committerBrad King <brad.king@kitware.com>2009-09-28 15:36:54 (GMT)
commit832f0a88f042d16b4afb049968ae1c167109d6a0 (patch)
tree9f14a5eed0c52a4a3af9f5ade60e644fdc71c0bc /CMakeLists.txt
parent9737ea074a5e199f5785f9f242c5ec80394b229f (diff)
downloadCMake-832f0a88f042d16b4afb049968ae1c167109d6a0.zip
CMake-832f0a88f042d16b4afb049968ae1c167109d6a0.tar.gz
CMake-832f0a88f042d16b4afb049968ae1c167109d6a0.tar.bz2
Install KWSys Copyright.txt as documentation
This commit adds KWSys configuration option KWSYS_INSTALL_DOC_DIR to specify the directory for installation of documentation. We use it to put the KWSys Copyright.txt file at the location ${KWSYS_INSTALL_DOC_DIR}/${KWSYS_NAMESPACE}/Copyright.txt in the project installation tree. This helps containing projects meet the license requirement to distribute the copyright and license with binary forms.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb16606..a8daaa2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -170,6 +170,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(KWSYS_USE_Process 1)
SET(KWSYS_USE_CommandLineArguments 1)
SET(KWSYS_HEADER_ROOT ${CMake_BINARY_DIR}/Source)
+ SET(KWSYS_INSTALL_DOC_DIR "${CMake_DOC_DEST}")
SUBDIRS(Source/kwsys)
#---------------------------------------------------------------------
@@ -340,6 +341,7 @@ SET(CMAKE_MAN_DIR "/man" CACHE STRING
"Install location for man pages (relative to prefix).")
MARK_AS_ADVANCED(CMAKE_DATA_DIR CMAKE_DOC_DIR CMAKE_MAN_DIR)
STRING(REGEX REPLACE "^/" "" CMake_DATA_DEST "${CMAKE_DATA_DIR}")
+STRING(REGEX REPLACE "^/" "" CMake_DOC_DEST "${CMAKE_DOC_DIR}")
# include special compile flags for some compilers
INCLUDE(CompileFlags.cmake)