summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-03-03 19:06:34 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-03 20:26:49 (GMT)
commit9f5bd180c8e0114ff153deeaa1690ce9eb250005 (patch)
treeb7f61037fb16f743b4bca5068c3033e49aea520f /CMakeLists.txt
parent76477267bda58d10b8e00229bffd841f9e73d041 (diff)
downloadCMake-9f5bd180c8e0114ff153deeaa1690ce9eb250005.zip
CMake-9f5bd180c8e0114ff153deeaa1690ce9eb250005.tar.gz
CMake-9f5bd180c8e0114ff153deeaa1690ce9eb250005.tar.bz2
Tests: Drop CMAKE_TEST_GENERATOR(|_TOOLSET) variables
s/CMAKE_TEST_GENERATOR/CMAKE_GENERATOR/g
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 1 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b9f96e2..a043838 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,9 +114,6 @@ endif()
#-----------------------------------------------------------------------
macro(CMAKE_SETUP_TESTING)
if(BUILD_TESTING)
- set(CMAKE_TEST_GENERATOR "${CMAKE_GENERATOR}")
- set(CMAKE_TEST_GENERATOR_TOOLSET "${CMAKE_GENERATOR_TOOLSET}")
-
set(CMAKE_TEST_SYSTEM_LIBRARIES 0)
foreach(util CURL EXPAT XMLRPC ZLIB)
if(CMAKE_USE_SYSTEM_${util})
@@ -547,7 +544,7 @@ endif()
# add a test
add_test(SystemInformationNew "${CMAKE_CMAKE_COMMAND}"
- --system-information -G "${CMAKE_TEST_GENERATOR}" )
+ --system-information -G "${CMAKE_GENERATOR}" )
# Install license file as it requires.
install(FILES Copyright.txt DESTINATION ${CMAKE_DOC_DIR})