summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2012-04-26 20:35:55 (GMT)
committerBrad King <brad.king@kitware.com>2012-04-26 20:39:54 (GMT)
commitd960de2f5410b6ed10aabeb71e09aec19d32d9d8 (patch)
tree0f3cbb5719d68891d16ee1a73f9da96f7436b610 /CMakeLists.txt
parenta7d0fb1470cc7c900abfff14a87039d353a8c2b3 (diff)
downloadCMake-d960de2f5410b6ed10aabeb71e09aec19d32d9d8.zip
CMake-d960de2f5410b6ed10aabeb71e09aec19d32d9d8.tar.gz
CMake-d960de2f5410b6ed10aabeb71e09aec19d32d9d8.tar.bz2
Require CMake 2.8.2 or higher to build CMake
Update the requirement specified in the top-level CMakeLists.txt file. Drop the special-case minimum required version of 2.8.0 because the new minimum subsumes it. Revert commit 6c611c6b (libarchive: Restore CMake 2.6.3 as minimum version, 2012-01-05) since our requirement now subsumes libarchive's.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 66f9b2d..8522cad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
#=============================================================================
# CMake - Cross Platform Makefile Generator
-# Copyright 2000-2011 Kitware, Inc., Insight Software Consortium
+# Copyright 2000-2012 Kitware, Inc., Insight Software Consortium
#
# Distributed under the OSI-approved BSD License (the "License");
# see accompanying file Copyright.txt for details.
@@ -9,7 +9,7 @@
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
# See the License for more information.
#=============================================================================
-CMAKE_MINIMUM_REQUIRED(VERSION 2.6.3 FATAL_ERROR)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.8.2 FATAL_ERROR)
SET(CMAKE_LEGACY_CYGWIN_WIN32 0) # Remove when CMake >= 2.8.4 is required
PROJECT(CMake)
@@ -324,10 +324,9 @@ MACRO (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Build or use system libarchive for CMake and CTest.
IF(CMAKE_USE_SYSTEM_LIBARCHIVE)
- IF(EXISTS ${CMAKE_ROOT}/Modules/FindLibArchive.cmake)
+ IF(EXISTS ${CMAKE_ROOT}/Modules/FindLibArchive.cmake) # added in 2.8.3
FIND_PACKAGE(LibArchive)
ELSE()
- CMAKE_MINIMUM_REQUIRED(VERSION 2.8.0 FATAL_ERROR)
INCLUDE(${CMake_SOURCE_DIR}/Modules/FindLibArchive.cmake)
ENDIF()
IF(NOT LibArchive_FOUND)