summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2004-06-25 18:04:48 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2004-06-25 18:04:48 (GMT)
commit15097cf35f660ed3865f60e70201e5d902b46b2d (patch)
tree4e093aaeb8a8962f2e403f4905f26381c7b093c7 /CMakeLists.txt
parent9d4b5e52c18ded5dd55fdd21f629ff9d13f99d8c (diff)
downloadCMake-15097cf35f660ed3865f60e70201e5d902b46b2d.zip
CMake-15097cf35f660ed3865f60e70201e5d902b46b2d.tar.gz
CMake-15097cf35f660ed3865f60e70201e5d902b46b2d.tar.bz2
ENH: Build expat as a part of default build
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 35b645f..c8836dc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,9 +57,16 @@ SET(KWSYS_USE_Process 1)
SET(KWSYS_HEADER_ROOT ${CMake_BINARY_DIR}/Source)
SUBDIRS(Source/kwsys)
+#-----------------------------------------------------------------------------
+# Build Curl library for CTest.
SET(CMAKE_BUILD_WITH_CURL 1)
SUBDIRS(Source/CTest/Curl)
+#-----------------------------------------------------------------------------
+# Build expat library for CMake and CTest.
+INCLUDE_DIRECTORIES(${CMake_BINARY_DIR}/Utilities)
+SUBDIRS(Utilities/cmexpat)
+
IF (UNIX)
INCLUDE (${CMake_SOURCE_DIR}/Modules/FindCurses.cmake OPTIONAL)
IF (CURSES_LIBRARY)