summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2003-06-23 12:58:58 (GMT)
committerBrad King <brad.king@kitware.com>2003-06-23 12:58:58 (GMT)
commitdc3fd5c26727ae81b57c4fa2b5559b6c1e36840c (patch)
treeed05e732bd914a3a9048b566f14cdffbba2eeb85 /CMakeLists.txt
parentc5890b8c2e5593752eaceeb19923917618d59e1f (diff)
downloadCMake-dc3fd5c26727ae81b57c4fa2b5559b6c1e36840c.zip
CMake-dc3fd5c26727ae81b57c4fa2b5559b6c1e36840c.tar.gz
CMake-dc3fd5c26727ae81b57c4fa2b5559b6c1e36840c.tar.bz2
ENH: Merged use of kwsys library.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58b0212..63f67bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,15 @@ IF(CMAKE_SYSTEM MATCHES "OSF1-V.*")
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -timplicit_local -no_implicit_include ")
ENDIF(NOT CMAKE_COMPILER_IS_GNUCXX)
ENDIF(CMAKE_SYSTEM MATCHES "OSF1-V.*")
+
+#-----------------------------------------------------------------------------
+# Create the kwsys library for CMake.
+SET(KWSYS_NAMESPACE cmsys)
+SET(KWSYS_USE_SystemTools 1)
+SET(KWSYS_USE_Directory 1)
+SET(KWSYS_HEADER_ROOT ${CMake_BINARY_DIR}/Source)
+SUBDIRS(Source/kwsys)
+
SUBDIRS(Source Modules Templates Utilities)
ENABLE_TESTING()