summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-01-26 14:51:50 (GMT)
committerCMake Topic Stage <kwrobot@kitware.com>2015-01-26 14:51:50 (GMT)
commit1337576b24feef973fca7cc45c695b495b3f8a5e (patch)
treeaccb2623fa2a26782346091e0fe3ce4606ac58c0 /CMakeLists.txt
parente71c35ff26df370121871dc7cc7fe9b585dac570 (diff)
parent0abd3e538eb92259e52c3d330e46dac7aa0be332 (diff)
downloadCMake-1337576b24feef973fca7cc45c695b495b3f8a5e.zip
CMake-1337576b24feef973fca7cc45c695b495b3f8a5e.tar.gz
CMake-1337576b24feef973fca7cc45c695b495b3f8a5e.tar.bz2
Merge topic 'curl-default-cainfo'
0abd3e53 cmake: Use a default CA path when not using system curl 6ce346c5 curl: Add CURL_CA_PATH option to CMake build process
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bdc160d..28fd02f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,6 +287,13 @@ macro (CMAKE_BUILD_UTILITIES)
if(CMAKE_TESTS_CDASH_SERVER)
set(CMAKE_CURL_TEST_URL "${CMAKE_TESTS_CDASH_SERVER}/user.php")
endif()
+ option(CMAKE_USE_OPENSSL "Use OpenSSL." OFF)
+ mark_as_advanced(CMAKE_USE_OPENSSL)
+ if(CMAKE_USE_OPENSSL)
+ set(CURL_CA_BUNDLE "" CACHE FILEPATH "Path to SSL CA Certificate Bundle")
+ set(CURL_CA_PATH "" CACHE PATH "Path to SSL CA Certificate Directory")
+ mark_as_advanced(CURL_CA_BUNDLE CURL_CA_PATH)
+ endif()
add_subdirectory(Utilities/cmcurl)
CMAKE_SET_TARGET_FOLDER(cmcurl "Utilities/3rdParty")
CMAKE_SET_TARGET_FOLDER(LIBCURL "Utilities/3rdParty")