summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2008-03-02 19:35:13 (GMT)
committerBrad King <brad.king@kitware.com>2008-03-02 19:35:13 (GMT)
commit16a415dd0c81a4a11cf6fa78755ce636e5ac3ab9 (patch)
treeb1fe8049b69e73ccc9b204a8f2e085530c0f1a61 /CMakeLists.txt
parentc9514dc0d186bedefe9fbe774505a20fd9b4dd89 (diff)
downloadCMake-16a415dd0c81a4a11cf6fa78755ce636e5ac3ab9.zip
CMake-16a415dd0c81a4a11cf6fa78755ce636e5ac3ab9.tar.gz
CMake-16a415dd0c81a4a11cf6fa78755ce636e5ac3ab9.tar.bz2
ENH: Simplify tests for building CMake itself with rpath support now that 2.4 is required to build.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ac6b835..ae4c9b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -436,16 +436,15 @@ ENDIF(BUILD_QtDialog)
# since this one has much better RPATH features than cmake 2.2.
# The executables are then built with the RPATH for the libraries outside
# the build tree, which is both the build and the install RPATH.
-IF (UNIX AND "${CMAKE_MAJOR_VERSION}${CMAKE_MINOR_VERSION}" GREATER 23)
+IF (UNIX)
IF( CMAKE_USE_SYSTEM_CURL OR CMAKE_USE_SYSTEM_ZLIB
OR CMAKE_USE_SYSTEM_EXPAT OR CMAKE_USE_SYSTEM_XMLRPC OR CURSES_NEED_RPATH OR QT_NEED_RPATH)
SET(CMAKE_SKIP_RPATH OFF CACHE INTERNAL "CMake built with RPATH.")
SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
SET(CMAKE_BUILD_WITH_INSTALL_RPATH TRUE)
- MESSAGE(STATUS "Enabling RPATH")
ENDIF(CMAKE_USE_SYSTEM_CURL OR CMAKE_USE_SYSTEM_ZLIB
OR CMAKE_USE_SYSTEM_EXPAT OR CMAKE_USE_SYSTEM_XMLRPC OR CURSES_NEED_RPATH OR QT_NEED_RPATH)
-ENDIF (UNIX AND "${CMAKE_MAJOR_VERSION}${CMAKE_MINOR_VERSION}" GREATER 23)
+ENDIF (UNIX)
# should we build the MFC dialog? (a macro defined in this file)