summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-24 21:33:11 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-24 21:33:11 (GMT)
commit7b299306fd83d1a9a5089f4bede1affb7e300996 (patch)
tree24f27c10ee6614e20068dbbe2a131fe593721221 /CMakeLists.txt
parent6414fa21fe1540dc1772fba1a4a711023e67e107 (diff)
downloadCMake-7b299306fd83d1a9a5089f4bede1affb7e300996.zip
CMake-7b299306fd83d1a9a5089f4bede1affb7e300996.tar.gz
CMake-7b299306fd83d1a9a5089f4bede1affb7e300996.tar.bz2
ENH: Allow empty endif() and such with CMake 2.4
This allows us to use empty endif() and similar block terminators when building with CMake 2.4. It is allowed by default with 2.6 already.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d32c442..d753cad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,6 +6,8 @@ ENDIF(COMMAND CMAKE_POLICY)
MARK_AS_ADVANCED(CMAKE_BACKWARDS_COMPATIBILITY)
+# Allow empty endif() and such with CMake 2.4.
+SET(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS 1)
#-----------------------------------------------------------------------