summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2014-04-07 13:49:13 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-08 17:06:10 (GMT)
commitc54be58309fbf9c2a5cfec8ba190c631e1db4a6c (patch)
treec6a26b0d8c412a123a336d3af842da72c800bcbf /CMakeLists.txt
parenteccc425af6ffeb52963cc2dd94a36a24c271108b (diff)
downloadCMake-c54be58309fbf9c2a5cfec8ba190c631e1db4a6c.zip
CMake-c54be58309fbf9c2a5cfec8ba190c631e1db4a6c.tar.gz
CMake-c54be58309fbf9c2a5cfec8ba190c631e1db4a6c.tar.bz2
KWSys 2014-04-07 (8b085635)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ 8b085635 | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' 39f98b5d..8b085635 Rolf Eike Beer (2): a99a9235 set the compile flags for older HP compilers to fix compilation 8b085635 MD5: avoid casting back and forth between size_t and int Change-Id: I6386b521dbaba2e4f9ed5b2be34a504b9c17fc36
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 977d57b..5e6a226 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -299,6 +299,13 @@ IF(NOT CMAKE_COMPILER_IS_GNUCXX)
ENDIF(CMAKE_SYSTEM MATCHES "OSF1-V.*")
IF(CMAKE_SYSTEM MATCHES "HP-UX")
SET(KWSYS_PLATFORM_CXX_TEST_EXTRA_FLAGS "+p")
+ IF(CMAKE_CXX_COMPILER_ID MATCHES "HP")
+ # it is known that version 3.85 fails and 6.25 works without these flags
+ IF(CMAKE_CXX_COMPILER_VERSION VERSION_LESS 4)
+ # use new C++ library and improved template support
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -AA +hpxstd98")
+ ENDIF()
+ ENDIF()
ENDIF(CMAKE_SYSTEM MATCHES "HP-UX")
ENDIF(NOT CMAKE_COMPILER_IS_GNUCXX)