summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Cole <david.cole@kitware.com>2009-10-20 18:31:10 (GMT)
committerDavid Cole <david.cole@kitware.com>2009-10-20 18:31:10 (GMT)
commite1458ae4ab97a4ac668fd9153c6624e9e0e526b5 (patch)
tree13ce1429eaee8b4ebf62d986412d1165c938c5c3 /CMakeLists.txt
parent78174651b696a8e20ae55291a3b157bcab412408 (diff)
downloadCMake-e1458ae4ab97a4ac668fd9153c6624e9e0e526b5.zip
CMake-e1458ae4ab97a4ac668fd9153c6624e9e0e526b5.tar.gz
CMake-e1458ae4ab97a4ac668fd9153c6624e9e0e526b5.tar.bz2
Add test of all available CPack generators. Add this test with the goal of increasing coverage of the cpack source code, even/especially when the underlying packager tool is not installed. The test does not fail if there is a cpack problem with a certain generator. I expect some generators will fail on every machine running a CMake dashboard.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8c213b..7223c90 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,12 +141,13 @@ MACRO(CMAKE_SETUP_TESTING)
# cmake.
SET(CMAKE_CTEST_COMMAND "${EXECUTABLE_OUTPUT_PATH}/ctest")
SET(CMAKE_CMAKE_COMMAND "${EXECUTABLE_OUTPUT_PATH}/cmake")
+ SET(CMAKE_CPACK_COMMAND "${EXECUTABLE_OUTPUT_PATH}/cpack")
ENDIF(BUILD_TESTING)
# configure some files for testing
CONFIGURE_FILE("${CMAKE_CURRENT_SOURCE_DIR}/Templates/CTestScript.cmake.in"
"${CMAKE_CURRENT_BINARY_DIR}/CTestScript.cmake"
- @ONLY)
+ @ONLY)
CONFIGURE_FILE(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage
${CMake_BINARY_DIR}/Tests/.NoDartCoverage)
CONFIGURE_FILE(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage