summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-05-30 13:55:49 (GMT)
committerKitware Robot <kwrobot@kitware.com>2018-05-30 13:56:00 (GMT)
commitfdb9d1ba042fb517da0bf03a3781dd7a3b506f69 (patch)
tree8ac328b1618f51bb07b50736f3432e6a6a14a484 /CMakeLists.txt
parente21245ecafae78ff2fd3947f95cc30eac68ed5e8 (diff)
parent6d7c0740556fb06689c4d332fac685d70d83b1fe (diff)
downloadCMake-fdb9d1ba042fb517da0bf03a3781dd7a3b506f69.zip
CMake-fdb9d1ba042fb517da0bf03a3781dd7a3b506f69.tar.gz
CMake-fdb9d1ba042fb517da0bf03a3781dd7a3b506f69.tar.bz2
Merge topic 'cmRemoveDuplicates'
6d7c074055 cmAlgorithms: Speed up cmRemoveDuplicates method 281f59536f IWYU: Define a macro to tell code it is preprocessing for iwyu Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !2101
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ee67cb..e20d770 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -285,7 +285,7 @@ if(CMake_RUN_IWYU)
message(FATAL_ERROR "CMake_RUN_IWYU is ON but include-what-you-use is not found!")
endif()
set(CMAKE_CXX_INCLUDE_WHAT_YOU_USE
- "${IWYU_COMMAND};-Xiwyu;--mapping_file=${CMake_SOURCE_DIR}/Utilities/IWYU/mapping.imp;-w")
+ "${IWYU_COMMAND};-Xiwyu;--mapping_file=${CMake_SOURCE_DIR}/Utilities/IWYU/mapping.imp;-w;-DCMAKE_IWYU")
endif()