summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-09-29 17:12:49 (GMT)
committerBrad King <brad.king@kitware.com>2016-09-29 17:12:49 (GMT)
commit97b6e17c336f36556981e9371af78f08f4d304bb (patch)
tree7dc0460ca15c03b1db59901390006efd16336c3a /CMakeLists.txt
parent5d29506811c5b75ae48e12de6c317f6440874215 (diff)
downloadCMake-97b6e17c336f36556981e9371af78f08f4d304bb.zip
CMake-97b6e17c336f36556981e9371af78f08f4d304bb.tar.gz
CMake-97b6e17c336f36556981e9371af78f08f4d304bb.tar.bz2
server-mode: Enable from bootstrapped CMake build
CMake is frequently built from source via bootstrap. There is no reason we cannot support server mode.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8e1aaf5..5ce3af2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -696,7 +696,7 @@ CMAKE_SETUP_TESTING()
# Check whether to build server mode or not:
set(CMake_HAVE_SERVER_MODE 0)
-if(NOT CMake_TEST_EXTERNAL_CMAKE AND NOT CMAKE_BOOTSTRAP AND CMAKE_USE_LIBUV)
+if(NOT CMake_TEST_EXTERNAL_CMAKE AND CMAKE_USE_LIBUV)
list(FIND CMAKE_CXX_COMPILE_FEATURES cxx_auto_type CMake_HAVE_CXX_AUTO_TYPE)
list(FIND CMAKE_CXX_COMPILE_FEATURES cxx_range_for CMake_HAVE_CXX_RANGE_FOR)
if(CMake_HAVE_CXX_AUTO_TYPE AND CMake_HAVE_CXX_RANGE_FOR)