summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2001-06-12 17:30:13 (GMT)
committerKen Martin <ken.martin@kitware.com>2001-06-12 17:30:13 (GMT)
commit583ac25e8fa4f17aa282837611624d20225a59e1 (patch)
tree1b00456a5594abd299c070b745bb102824488fb9 /CMakeLists.txt
parent19b2f84ac7dd9a64661124971704d694e9dfbda2 (diff)
downloadCMake-583ac25e8fa4f17aa282837611624d20225a59e1.zip
CMake-583ac25e8fa4f17aa282837611624d20225a59e1.tar.gz
CMake-583ac25e8fa4f17aa282837611624d20225a59e1.tar.bz2
support testing
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..8e95ecf
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,40 @@
+PROJECT(CMake)
+
+SUBDIRS(Source)
+
+# Include the standard Dart testing module
+INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+
+#
+# Variables used for submitting testing results. These will change from
+# project to project. Most likely, you will change DROP_SITE,
+# DROP_SITE_PASSWORD and TRIGGER_SITE.
+#
+IF (BUILD_TESTING)
+ ENABLE_TESTING()
+
+ # Dart server to submit results (used by client)
+ SET (DROP_SITE "public.kitware.com" CACHE INTERNAL
+ "FTP site for submitting testing results")
+ SET (DROP_LOCATION "/incoming" CACHE INTERNAL
+ "Directory on FTP site to place testing results")
+ SET (DROP_SITE_USER "anonymous" CACHE INTERNAL
+ "Username for FTP site for submitting testing results")
+ SET (DROP_SITE_PASSWORD "cmake-tester@somewhere.com" CACHE INTERNAL
+ "Password for FTP site for submitting testing results")
+ SET (TRIGGER_SITE
+ "http://${DROP_SITE}/cgi-bin/Submit-CMake-TestingResults.pl"
+ CACHE INTERNAL
+ "Web site to signal when testing results have been submitted")
+
+ # Dart server configuration
+ SET (CVS_WEB_URL "http://${DROP_SITE}/cgi-bin/cmakecvsweb.cgi/CMake/"
+ CACHE INTERNAL "URL for revision control system")
+ SET (DOXYGEN_URL "http://${DROP_SITE}/CMake/Doxygen/html/"
+ CACHE INTERNAL "URL for source code documentation")
+ SET (GNATS_WEB_URL "http://${DROP_SITE}/cgi-bin/gnatsweb.pl/CMake/"
+ CACHE INTERNAL "URL for bug tracker")
+
+ENDIF (BUILD_TESTING)
+
+