summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2013-01-10 17:34:34 (GMT)
committerBrad King <brad.king@kitware.com>2013-01-11 16:34:55 (GMT)
commit6318834b95fb4e666f9c135a883bb953579c3c8a (patch)
tree478758e53047add158074b4518a93602268a2c20 /CMakeLists.txt
parent495fa24d70ce4c5b594e15cae464af243a127fb8 (diff)
downloadCMake-6318834b95fb4e666f9c135a883bb953579c3c8a.zip
CMake-6318834b95fb4e666f9c135a883bb953579c3c8a.tar.gz
CMake-6318834b95fb4e666f9c135a883bb953579c3c8a.tar.bz2
KWSys 2013-01-10 (608d6b47)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ 608d6b47 | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' fc60c8b8..608d6b47 Rolf Eike Beer (6): 297758a5 SystemInformation: fix conversion warning 79ef34ef SystemInformation: fix calling kwsysProcess_WaitForData() f1068caf SystemInformation: speed up copying process data 7dfc27d5 SystemInformation: check CPU vendor and SSE support on OpenBSD 494d9d7a SystemInformation: get stepping code on Intel Macs 608d6b47 SystemInformation: determine processor features on Intel Macs Change-Id: I7f5bc5b7af2bf7d4e5c1ee291c286add0f17a7d5
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bfcab0..5df5a74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -603,6 +603,13 @@ IF(KWSYS_USE_SystemInformation)
COMPILE_DEFINITIONS KWSYS_SYS_HAS_MPCTL_H=1)
ENDIF()
ENDIF()
+ IF(CMAKE_SYSTEM MATCHES "BSD")
+ CHECK_INCLUDE_FILES("machine/cpu.h" KWSYS_SYS_HAS_MACHINE_CPU_H)
+ IF(KWSYS_SYS_HAS_MACHINE_CPU_H)
+ SET_PROPERTY(SOURCE SystemInformation.cxx APPEND PROPERTY
+ COMPILE_DEFINITIONS KWSYS_SYS_HAS_MACHINE_CPU_H=1)
+ ENDIF()
+ ENDIF()
IF(KWSYS_LFS_AVAILABLE AND NOT KWSYS_LFS_DISABLE)
SET(KWSYS_PLATFORM_CXX_TEST_DEFINES -DKWSYS_HAS_LFS=1)
ENDIF()