summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2015-12-09 16:45:28 (GMT)
committerBrad King <brad.king@kitware.com>2015-12-10 14:32:49 (GMT)
commit2b7a47d76ac5289acc1572917b8ac8266ffec0ca (patch)
tree8c44bd9c5fb74c3569e977ac0587d5e96409a7a6 /CMakeLists.txt
parentd5d90f5ec8792fafbe754e2c943825267f7aaff1 (diff)
downloadCMake-2b7a47d76ac5289acc1572917b8ac8266ffec0ca.zip
CMake-2b7a47d76ac5289acc1572917b8ac8266ffec0ca.tar.gz
CMake-2b7a47d76ac5289acc1572917b8ac8266ffec0ca.tar.bz2
KWSys 2015-12-09 (cdcf4c47)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ cdcf4c47 | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' 6bfc1aef..cdcf4c47 Brad King (2): 452b10d5 FundamentalType: Drop KWSYS_CAN_CONVERT_UI64_TO_DOUBLE macro cdcf4c47 Drop the CPU.h component of KWSys
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ce7f563..b859e79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,7 +124,6 @@ IF(KWSYS_STANDALONE OR CMake_SOURCE_DIR)
SET(KWSYS_USE_FStream 1)
SET(KWSYS_USE_String 1)
SET(KWSYS_USE_SystemInformation 1)
- SET(KWSYS_USE_CPU 1)
ENDIF()
# Enforce component dependencies.
@@ -425,13 +424,6 @@ IF(KWSYS_USE_FundamentalType)
ENDIF()
ENDFOREACH()
- IF(KWSYS_USE___INT64)
- KWSYS_PLATFORM_CXX_TEST(KWSYS_CAN_CONVERT_UI64_TO_DOUBLE
- "Checking whether unsigned __int64 can convert to double" DIRECT)
- ELSE()
- SET(KWSYS_CAN_CONVERT_UI64_TO_DOUBLE 1)
- ENDIF()
-
# Check signedness of "char" type.
KWSYS_PLATFORM_CXX_TEST_RUN(KWSYS_CHAR_IS_SIGNED
"Checking whether char is signed" DIRECT)
@@ -749,7 +741,7 @@ ENDFOREACH()
# Add selected C components.
FOREACH(c
- Process Base64 Encoding FundamentalType MD5 Terminal System String CPU
+ Process Base64 Encoding FundamentalType MD5 Terminal System String
)
IF(KWSYS_USE_${c})
# Use the corresponding header file.