summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2015-06-03 18:25:01 (GMT)
committerBrad King <brad.king@kitware.com>2015-06-04 13:22:48 (GMT)
commit6cafd8ed0bc8458ba2c6eb0e792c894cf4f37f90 (patch)
treeb7f546925df589e72e6f23e31c376d641ad185f3 /CMakeLists.txt
parentee71b75133d3e515172b5fbe3dccf7d3906f5a19 (diff)
downloadCMake-6cafd8ed0bc8458ba2c6eb0e792c894cf4f37f90.zip
CMake-6cafd8ed0bc8458ba2c6eb0e792c894cf4f37f90.tar.gz
CMake-6cafd8ed0bc8458ba2c6eb0e792c894cf4f37f90.tar.bz2
KWSys 2015-06-03 (8533a79b)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ 8533a79b | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' 61e0419f..8533a79b Zack Galbreath (1): 8533a79b SystemInformation: Add GetLoadAverage() method
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c88e888..7eb678b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -786,6 +786,15 @@ IF(KWSYS_USE_SystemInformation)
SET_PROPERTY(SOURCE SystemInformation.cxx APPEND PROPERTY
COMPILE_DEFINITIONS KWSYS_BUILD_SHARED=1)
ENDIF()
+
+ IF(UNIX AND NOT CYGWIN)
+ KWSYS_PLATFORM_CXX_TEST(KWSYS_CXX_HAS_GETLOADAVG
+ "Checking whether CXX compiler has getloadavg" DIRECT)
+ IF(KWSYS_CXX_HAS_GETLOADAVG)
+ SET_PROPERTY(SOURCE SystemInformation.cxx APPEND PROPERTY
+ COMPILE_DEFINITIONS KWSYS_CXX_HAS_GETLOADAVG=1)
+ ENDIF()
+ ENDIF()
ENDIF()
#-----------------------------------------------------------------------------