summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2014-03-12 14:58:16 (GMT)
committerBrad King <brad.king@kitware.com>2014-03-12 15:04:37 (GMT)
commitc1dde67e62868529aaea807a3664b2eef9389a5b (patch)
tree4e432d4f1afa5c2349f30aa0b9dc5aa66923a64c /CMakeLists.txt
parentc236691b32f4532d4da6db77322b4446e3802e3f (diff)
downloadCMake-c1dde67e62868529aaea807a3664b2eef9389a5b.zip
CMake-c1dde67e62868529aaea807a3664b2eef9389a5b.tar.gz
CMake-c1dde67e62868529aaea807a3664b2eef9389a5b.tar.bz2
KWSys 2014-03-12 (dd873734)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ dd873734 | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' 9c653603..dd873734 Brad King (1): 88c5a768 Set policy CMP0025 to NEW within KWSys Stephen Kelly (1): dd873734 SystemTools: Remove some unnecessary c_str() calls Change-Id: I5487fefcb3e44875ed5748fb2c4ab8302fcef984
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 52bcfe1..977d57b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -85,6 +85,9 @@
# written.
CMAKE_MINIMUM_REQUIRED(VERSION 2.6.3 FATAL_ERROR)
+IF(POLICY CMP0025)
+ CMAKE_POLICY(SET CMP0025 NEW)
+ENDIF()
#-----------------------------------------------------------------------------
# If a namespace is not specified, use "kwsys" and enable testing.