summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2015-08-24 22:44:47 (GMT)
committerBrad King <brad.king@kitware.com>2015-08-31 13:54:42 (GMT)
commitca96be228345d93f51cb4edbd0428b709f529b84 (patch)
tree1293b9e310c72b30468fd9e8eeae0b9958a800d6 /CMakeLists.txt
parent9a59ae5c198f7c413bcaf29f1ab107a265677b95 (diff)
downloadCMake-ca96be228345d93f51cb4edbd0428b709f529b84.zip
CMake-ca96be228345d93f51cb4edbd0428b709f529b84.tar.gz
CMake-ca96be228345d93f51cb4edbd0428b709f529b84.tar.bz2
KWSys 2015-08-24 (cdaf522c)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ cdaf522c | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' dad68c33..cdaf522c Brad King (2): c8e5d1b2 Pass C++ standard flags to SunPro in standalone build 91cb7820 Remove unused source file "CMakeEmptyInputFile.in" James Johnston (6): 0bca555e Process: Test running a process many times to discover resource leaks 52788bb8 SystemTools: Remove trailing whitespace. 8122214c cmake: Set CMAKE_LEGACY_CYGWIN_WIN32 to 0. 389d416b SystemTools: Clarify/simplify behavior of FileExists 8970cd56 SystemTools: Added new TestFileAccess function. cdaf522c SystemTools: Add honor_umask parameter to SetPermissions. Mattias Ellert (1): b9df3e48 Fix implementation of KWSYS_PROPERTIES_C
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 017d619..c1229ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -91,6 +91,7 @@ ENDIF()
IF(POLICY CMP0056)
CMAKE_POLICY(SET CMP0056 NEW)
ENDIF()
+SET(CMAKE_LEGACY_CYGWIN_WIN32 0)
#-----------------------------------------------------------------------------
# If a namespace is not specified, use "kwsys" and enable testing.
@@ -311,6 +312,15 @@ IF(NOT CMAKE_COMPILER_IS_GNUCXX)
ENDIF()
ENDIF()
ENDIF()
+IF(KWSYS_STANDALONE)
+ IF(CMAKE_CXX_COMPILER_ID STREQUAL SunPro)
+ IF(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.13)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++03")
+ ELSE()
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -library=stlport4")
+ ENDIF()
+ ENDIF()
+ENDIF()
#-----------------------------------------------------------------------------
# Configure Large File Support.
@@ -1071,7 +1081,7 @@ IF(KWSYS_ENABLE_C AND KWSYS_C_SRCS)
# Apply user-defined target properties to the library.
IF(KWSYS_PROPERTIES_C)
- SET_TARGET_PROPERTIES(${KWSYS_NAMESPACE} PROPERTIES
+ SET_TARGET_PROPERTIES(${KWSYS_NAMESPACE}_c PROPERTIES
${KWSYS_PROPERTIES_C}
)
ENDIF()