summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-07-07 15:23:13 (GMT)
committerBrad King <brad.king@kitware.com>2014-07-07 15:32:06 (GMT)
commit38d3fe0785e7691d19d015b43d2bb9d6d17bbd1f (patch)
tree26624d1a40d7c2a34e65bf195e79670b3cbe43c5 /CMakeLists.txt
parent61be345115b5f2c402286be7fa3e6df0c2f5f0ac (diff)
downloadCMake-38d3fe0785e7691d19d015b43d2bb9d6d17bbd1f.zip
CMake-38d3fe0785e7691d19d015b43d2bb9d6d17bbd1f.tar.gz
CMake-38d3fe0785e7691d19d015b43d2bb9d6d17bbd1f.tar.bz2
Tests: Build and test KWIML even when testing an external CMake
The CMake_TEST_EXTERNAL_CMAKE option added by commit 9608ef6f (Tests: Optionally configure tests exclusively, 2014-03-03) is intended to allow one to run the CMake test suite with a compiler that may not be supported for hosting the build of CMake itself. However, we currently use the CMake test infrastructure to test KWIML everywhere that CMake supports. In order to continue testing KWIML even in places that CMake itself does not build, include it even when testing an external CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 5 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41ff4a6..e210f74 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -201,12 +201,6 @@ endmacro()
#-----------------------------------------------------------------------
macro (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
- # Create the KWIML library for CMake.
- set(KWIML cmIML)
- set(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
- add_subdirectory(Utilities/KWIML)
-
- #---------------------------------------------------------------------
# Create the kwsys library for CMake.
set(KWSYS_NAMESPACE cmsys)
set(KWSYS_USE_SystemTools 1)
@@ -465,6 +459,11 @@ if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
set(CMAKE_TESTS_CDASH_SERVER "http://open.cdash.org")
endif()
+# Create the KWIML library for CMake.
+set(KWIML cmIML)
+set(KWIML_HEADER_ROOT ${CMake_BINARY_DIR}/Utilities)
+add_subdirectory(Utilities/KWIML)
+
if(NOT CMake_TEST_EXTERNAL_CMAKE)
# build the utilities (a macro defined in this file)
CMAKE_BUILD_UTILITIES()