summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2020-03-06 14:24:38 (GMT)
committerKitware Robot <kwrobot@kitware.com>2020-03-06 14:24:45 (GMT)
commit21bbc56fb554a6d86e8889e97c842423c5529f9b (patch)
treef778d303d259c30687ebfa4ff309767c1acabe35 /CMakeLists.txt
parent6deb9da277636813db11b331882922d46767664f (diff)
parent917db8163d645eb1dfe61ee9d74eb373fe0b4b2f (diff)
downloadCMake-21bbc56fb554a6d86e8889e97c842423c5529f9b.zip
CMake-21bbc56fb554a6d86e8889e97c842423c5529f9b.tar.gz
CMake-21bbc56fb554a6d86e8889e97c842423c5529f9b.tar.bz2
Merge topic 'cmstd-IBM-i'
917db8163d cmstd: Remove -isystem option for IBM i (OS400) Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !4430
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88dacdc..cf67a66 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -367,7 +367,7 @@ macro (CMAKE_BUILD_UTILITIES)
# Setup third-party libraries.
# Everything in the tree should be able to include files from the
# Utilities directory.
- if (CMAKE_SYSTEM_NAME STREQUAL "AIX" AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ if ((CMAKE_SYSTEM_NAME STREQUAL "AIX" OR CMAKE_SYSTEM_NAME STREQUAL "OS400") AND CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
# using -isystem option generate error "template with C linkage"
include_directories("${CMake_SOURCE_DIR}/Utilities/std")
else()