summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorErofeevK <erofeev.info@gmail.com>2018-04-16 06:48:31 (GMT)
committerBrad King <brad.king@kitware.com>2018-04-16 15:33:52 (GMT)
commitf5f72ff844a3130568dbc62517401c5727fcf9ec (patch)
treec152256724804e30c6995cb59de4278f46c99239 /CMakeLists.txt
parent61fd4c742013a7f9139db190f936703b656540ff (diff)
downloadCMake-f5f72ff844a3130568dbc62517401c5727fcf9ec.zip
CMake-f5f72ff844a3130568dbc62517401c5727fcf9ec.tar.gz
CMake-f5f72ff844a3130568dbc62517401c5727fcf9ec.tar.bz2
Explicitly require LibUV 1.10 or higher to build CMake
CMake 3.11 now uses `uv_translate_sys_error` introduced in LibUV 1.10.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6623959..3ab679e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -546,7 +546,7 @@ macro (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Build libuv library.
if(CMAKE_USE_SYSTEM_LIBUV)
- find_package(LibUV 1.0.0)
+ find_package(LibUV 1.10.0)
if(NOT LIBUV_FOUND)
message(FATAL_ERROR
"CMAKE_USE_SYSTEM_LIBUV is ON but a libuv is not found!")