summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2018-10-17 18:24:13 (GMT)
committerBrad King <brad.king@kitware.com>2018-10-17 18:29:16 (GMT)
commit95b4b9137ab5af70671f88ed9e47ea8e173f748a (patch)
tree477af040d5d5e32d32e58e0377da1efba92063df /CMakeLists.txt
parent4fc8e8b023c4ebce94a8baacbc086b72ec399aba (diff)
downloadCMake-95b4b9137ab5af70671f88ed9e47ea8e173f748a.zip
CMake-95b4b9137ab5af70671f88ed9e47ea8e173f748a.tar.gz
CMake-95b4b9137ab5af70671f88ed9e47ea8e173f748a.tar.bz2
Declare support for CMake versions through 3.12 for own build
CMake 3.12 introduced a `...<max>` syntax in the version given to `cmake_minimum_required` to automatically set policies to NEW up to that version. Use it to avoid listing policies explicitly. The syntax is compatible with older versions of CMake such that they use the extended version string for the `CMAKE_MINIMUM_REQUIRED_VERSION` variable (which we don't use) but otherwise ignore it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e88e925..ee987d0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
# Distributed under the OSI-approved BSD 3-Clause License. See accompanying
# file Copyright.txt or https://cmake.org/licensing for details.
-cmake_minimum_required(VERSION 3.1 FATAL_ERROR)
+cmake_minimum_required(VERSION 3.1...3.12 FATAL_ERROR)
set(CMAKE_USER_MAKE_RULES_OVERRIDE_C ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideC.cmake)
set(CMAKE_USER_MAKE_RULES_OVERRIDE_CXX ${CMAKE_CURRENT_SOURCE_DIR}/Source/Modules/OverrideCXX.cmake)
project(CMake)