summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndy Cedilnik <andy.cedilnik@kitware.com>2005-01-18 13:58:27 (GMT)
committerAndy Cedilnik <andy.cedilnik@kitware.com>2005-01-18 13:58:27 (GMT)
commit1540067e20cbf2d4a09214a2054b2090d439a8ff (patch)
tree5cbba4a4c0a3ee1c861b12ed5d5280dd214406b7 /CMakeLists.txt
parent3e7366e5c2533f8c2a8addd6e785907a455a0517 (diff)
downloadCMake-1540067e20cbf2d4a09214a2054b2090d439a8ff.zip
CMake-1540067e20cbf2d4a09214a2054b2090d439a8ff.tar.gz
CMake-1540067e20cbf2d4a09214a2054b2090d439a8ff.tar.bz2
ENH: Add uninstall. This is not really a feature but more of an example on how to do it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de7326f..bf51e8a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,3 +130,11 @@ IF(WIN32)
ENDIF(NOT BORLAND)
ENDIF(NOT UNIX)
ENDIF(WIN32)
+
+CONFIGURE_FILE(
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake.in"
+ "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
+ IMMEDIATE @ONLY)
+
+ADD_CUSTOM_TARGET(uninstall
+ "${CMAKE_COMMAND}" -P "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake")