summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2011-02-24 20:14:08 (GMT)
committerBrad King <brad.king@kitware.com>2011-02-24 20:14:08 (GMT)
commitc3e452e944f915975d13d89023cd43ed3dba5221 (patch)
treea12ae00856e6f1e5fbcd882c0a3089a743a2216d /CMakeLists.txt
parenta9841e6e9aae1f2df0e3d94031dc3816c269d4b5 (diff)
downloadCMake-c3e452e944f915975d13d89023cd43ed3dba5221.zip
CMake-c3e452e944f915975d13d89023cd43ed3dba5221.tar.gz
CMake-c3e452e944f915975d13d89023cd43ed3dba5221.tar.bz2
Require at least CMake 2.6.3 to build current CMake
Remove some cruft left for supporting builds with CMake 2.4.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 2 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 23525c4..7b0f6b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
#=============================================================================
# CMake - Cross Platform Makefile Generator
-# Copyright 2000-2009 Kitware, Inc., Insight Software Consortium
+# Copyright 2000-2011 Kitware, Inc., Insight Software Consortium
#
# Distributed under the OSI-approved BSD License (the "License");
# see accompanying file Copyright.txt for details.
@@ -9,12 +9,9 @@
# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
# See the License for more information.
#=============================================================================
-CMAKE_MINIMUM_REQUIRED(VERSION 2.4.5 FATAL_ERROR)
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6.3 FATAL_ERROR)
SET(CMAKE_LEGACY_CYGWIN_WIN32 0) # Remove when CMake >= 2.8.4 is required
PROJECT(CMake)
-IF(COMMAND CMAKE_POLICY)
- CMAKE_POLICY(SET CMP0003 NEW)
-ENDIF(COMMAND CMAKE_POLICY)
IF(CMAKE_BOOTSTRAP)
# Running from bootstrap script. Set local variable and remove from cache.
@@ -24,18 +21,8 @@ ENDIF()
MARK_AS_ADVANCED(CMAKE_BACKWARDS_COMPATIBILITY)
-# Allow empty endif() and such with CMake 2.4.
-SET(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS 1)
-
SET(CMake_BIN_DIR ${CMake_BINARY_DIR}/bin)
-IF(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.4)
- # Since the built CMake will install itself instead of the
- # generating CMake, tell it that the install rules were generated
- # by CMake 2.4.
- INSTALL(CODE "SET(CMAKE_INSTALL_SELF_2_4 1)")
-ENDIF()
-
IF("${CMake_SOURCE_DIR}" STREQUAL "${CMAKE_SOURCE_DIR}")
# Disallow architecture-specific try_run. It may not run on the host.
MACRO(TRY_RUN)