summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2001-09-27 19:54:47 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2001-09-27 19:54:47 (GMT)
commitd55f530012487694f2a9924d8de6d50181fb2aad (patch)
tree42b062fee50076e7b8549af4465f71cdbdedb3cf /CMakeLists.txt
parentcc768c86c62aa5c6ea9dfe5c215bfe19dd991e3a (diff)
downloadCMake-d55f530012487694f2a9924d8de6d50181fb2aad.zip
CMake-d55f530012487694f2a9924d8de6d50181fb2aad.tar.gz
CMake-d55f530012487694f2a9924d8de6d50181fb2aad.tar.bz2
BUG: fix install prefix
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a323468..9412e67 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,10 @@ SUBDIRS(Source Modules Templates)
# Include the standard Dart testing module
INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+INCLUDE (${CMAKE_BINARY_DIR}/Source/InitialConfigureFlags.cmake)
+IF(CMAKE_CONFIGURE_INSTALL_PREFIX)
+ SET(CMAKE_INSTALL_PREFIX ${CMAKE_CONFIGURE_INSTALL_PREFIX} )
+ENDIF(CMAKE_CONFIGURE_INSTALL_PREFIX)
# use the ansi CXX compile flag for building cmake
IF (CMAKE_ANSI_CXXFLAGS)