summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2003-01-10 22:31:34 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2003-01-10 22:31:34 (GMT)
commitc81f64d3b937d89f0f372b8e624f53546a276958 (patch)
tree676e6c5eadff87c9d1eb6e3442977c832eca9ba4 /CMakeLists.txt
parent3547363ac0de96b17becceb570d9056f5506da67 (diff)
downloadCMake-c81f64d3b937d89f0f372b8e624f53546a276958.zip
CMake-c81f64d3b937d89f0f372b8e624f53546a276958.tar.gz
CMake-c81f64d3b937d89f0f372b8e624f53546a276958.tar.bz2
ENH: make it work with cmake 1.6 with no backwards compatibility
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de4cc94..f5b58e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,15 @@
PROJECT(CMake)
+IF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 1.4)
+ IF(CMAKE_GENERATOR MATCHES "Visual Studio 7")
+ SET(CMAKE_SKIP_COMPATIBILITY_TESTS 1)
+ ENDIF(CMAKE_GENERATOR MATCHES "Visual Studio 7")
+ IF(CMAKE_GENERATOR MATCHES "Visual Studio 6")
+ SET(CMAKE_SKIP_COMPATIBILITY_TESTS 1)
+ ENDIF(CMAKE_GENERATOR MATCHES "Visual Studio 6")
+ INCLUDE (${CMAKE_ROOT}/Modules/CMakeBackwardCompatibilityCXX.cmake)
+ENDIF(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 1.4)
+
IF(CMAKE_SYSTEM MATCHES "OSF1-V.*")
IF(NOT CMAKE_COMPILER_IS_GNUCXX)
SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -timplicit_local -no_implicit_include ")