summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Upstream <kwrobot@kitware.com>2017-02-06 15:00:05 (GMT)
committerBrad King <brad.king@kitware.com>2017-02-06 18:01:39 (GMT)
commit95983ed8453f9167077821aea347ba1a87e92eac (patch)
treef99dabfa101adf8250dbe640c257161bd77862b0 /CMakeLists.txt
parent219c7bdcb16cd1dfe2e72befa4334c5b8147e1d7 (diff)
downloadCMake-95983ed8453f9167077821aea347ba1a87e92eac.zip
CMake-95983ed8453f9167077821aea347ba1a87e92eac.tar.gz
CMake-95983ed8453f9167077821aea347ba1a87e92eac.tar.bz2
KWSys 2017-02-06 (ef673998)
Code extracted from: https://gitlab.kitware.com/utils/kwsys.git at commit ef6739982f686648ef5ae6902aaf5fbaad891bce (master). Upstream Shortlog ----------------- Ben Boeckel (1): 8d8c86b5 testConsoleBuf: tighten the check for the /utf-8 flag Gregor Jasny (1): d6b87625 SystemTools: Add helper function to check for FIFO file type
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4fe8a7..de68118 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -946,7 +946,7 @@ IF(KWSYS_STANDALONE OR CMake_SOURCE_DIR)
testConsoleBuf
)
IF("x${CMAKE_CXX_COMPILER_ID}" STREQUAL "xMSVC" AND
- NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS "19.0")
+ CMAKE_CXX_COMPILER_VERSION VERSION_GREATER "19.0.23506")
set_property(SOURCE testConsoleBuf.cxx testConsoleBufChild.cxx PROPERTY COMPILE_FLAGS /utf-8)
ENDIF()
SET_PROPERTY(SOURCE testConsoleBuf.cxx APPEND PROPERTY COMPILE_DEFINITIONS