summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2014-10-31 17:09:11 (GMT)
committerBrad King <brad.king@kitware.com>2014-10-31 17:11:53 (GMT)
commit72b5b48040ed65fdb54b8ffeb3326b456586b8c8 (patch)
tree206a79c8cf49abb52943e86ba35d8688b40abf6b /CMakeLists.txt
parenta79ff0e4ed526f8ac0bb8f00201abf3d145fd7dd (diff)
downloadCMake-72b5b48040ed65fdb54b8ffeb3326b456586b8c8.zip
CMake-72b5b48040ed65fdb54b8ffeb3326b456586b8c8.tar.gz
CMake-72b5b48040ed65fdb54b8ffeb3326b456586b8c8.tar.bz2
KWSys 2014-10-31 (88c8cc7f)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ 88c8cc7f | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' 29ffaf43..88c8cc7f Ben Boeckel (11): 9bf03363 Avoid if() quoted auto-dereference 771e0f22 DynamicLoader: use strings for arguments 86e20d68 Directory: remove extra define 6cc24510 SystemTools: use strings in environment functions bab5b1f2 SystemTools: add string overload for ReplaceString f3fb01cf SystemTools: use strings for path-related APIs 0dfbe56d SystemTools: use strings for making C identifiers 4690fc8d SystemTools: use strings in registry function 1b762a41 SystemTools: search for characters 4a060347 SystemInformation: use %ls for WCHAR* format specifiers d31f7b12 SystemTools: remove unused variable Brad King (1): 88c8cc7f Fix configure_file call to use COPYONLY, not COPY_ONLY Clinton Stimpson (1): 5bf91dda SystemTools: Use extended length path for copying files. Change-Id: I16e8e55dea1c171c04f9c7d04ae3c575531097c3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ca4360..2292d64 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -265,7 +265,7 @@ STRING(COMPARE EQUAL "${PROJECT_SOURCE_DIR}" "${PROJECT_BINARY_DIR}"
KWSYS_IN_SOURCE_BUILD)
IF(NOT KWSYS_IN_SOURCE_BUILD)
CONFIGURE_FILE(${PROJECT_SOURCE_DIR}/kwsysPrivate.h
- ${PROJECT_BINARY_DIR}/kwsysPrivate.h COPY_ONLY IMMEDIATE)
+ ${PROJECT_BINARY_DIR}/kwsysPrivate.h COPYONLY IMMEDIATE)
ENDIF(NOT KWSYS_IN_SOURCE_BUILD)
# Select plugin module file name convention.
@@ -1075,7 +1075,7 @@ ENDIF(KWSYS_ENABLE_C AND KWSYS_C_SRCS)
ADD_DEFINITIONS("-DKWSYS_NAMESPACE=${KWSYS_NAMESPACE}")
# Disable deprecation warnings for standard C functions.
-IF(MSVC OR (WIN32 AND "${CMAKE_C_COMPILER_ID}" MATCHES "^(Intel)$"))
+IF(MSVC OR (WIN32 AND CMAKE_C_COMPILER_ID STREQUAL "Intel"))
ADD_DEFINITIONS(
-D_CRT_NONSTDC_NO_DEPRECATE
-D_CRT_SECURE_NO_DEPRECATE
@@ -1232,7 +1232,7 @@ IF(KWSYS_STANDALONE OR CMake_SOURCE_DIR)
ENDFOREACH(n)
# Some Apple compilers produce bad optimizations in this source.
- IF(APPLE AND "${CMAKE_C_COMPILER_ID}" MATCHES "^(GNU|LLVM)$")
+ IF(APPLE AND CMAKE_C_COMPILER_ID MATCHES "^(GNU|LLVM)$")
SET_SOURCE_FILES_PROPERTIES(testProcess.c PROPERTIES COMPILE_FLAGS -O0)
ELSEIF(CMAKE_C_COMPILER_ID STREQUAL "XL")
# Tell IBM XL not to warn about our test infinite loop