summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-11-17 15:47:25 (GMT)
committerBrad King <brad.king@kitware.com>2017-11-17 15:51:02 (GMT)
commit08353542e578cf756573c41ec4696dbf1c6513f0 (patch)
treee73d229585ac0aa5a30e8c834568c6ad5336bef0 /CMakeLists.txt
parent6e078505444faf3b140e9032ddfdd23d3d5e3fd6 (diff)
downloadCMake-08353542e578cf756573c41ec4696dbf1c6513f0.zip
CMake-08353542e578cf756573c41ec4696dbf1c6513f0.tar.gz
CMake-08353542e578cf756573c41ec4696dbf1c6513f0.tar.bz2
clang-tidy: Clarify comment explaining purpose of CLANG_TIDY_SHA1
Suggested-by: Bill Hoffman <bill.hoffman@kitware.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f14f62f..72ad7f5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -251,7 +251,12 @@ if(CMake_RUN_CLANG_TIDY)
endif()
set(CMAKE_CXX_CLANG_TIDY "${CLANG_TIDY_COMMAND}")
- # provide definitions for targets that require a rebuild once .clang-tidy changes
+ # Create a preprocessor definition that depends on .clang-tidy content so
+ # the compile command will change when .clang-tidy changes. This ensures
+ # that a subsequent build re-runs clang-tidy on all sources even if they
+ # do not otherwise need to be recompiled. Nothing actually uses this
+ # definition. We add it to targets on which we run clang-tidy just to
+ # get the build dependency on the .clang-tidy file.
file(SHA1 ${CMAKE_CURRENT_SOURCE_DIR}/.clang-tidy clang_tidy_sha1)
set(CLANG_TIDY_DEFINITIONS "CLANG_TIDY_SHA1=${clang_tidy_sha1}")
unset(clang_tidy_sha1)