summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-11-03 15:18:37 (GMT)
committerBrad King <brad.king@kitware.com>2016-11-10 13:26:54 (GMT)
commit31bb727f3b239b541e1ff5679b3c461e9a05f227 (patch)
tree6bbc228075d0546e9cd51e0858c66b7e83f122fb /CMakeLists.txt
parent53048afa8dc24327d82a1ff0f78801e1f344a4b6 (diff)
downloadCMake-31bb727f3b239b541e1ff5679b3c461e9a05f227.zip
CMake-31bb727f3b239b541e1ff5679b3c461e9a05f227.tar.gz
CMake-31bb727f3b239b541e1ff5679b3c461e9a05f227.tar.bz2
librhash: Build the library within CMake
Update `ustd.h` to include KWSys Large File Support configuration so that consistent stream libraries are used (on AIX with XL). Add a `cm_rhash.h` header to include the CMake-provided copy of the `rhash.h` header from CMake sources.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a5702e1..82a34d3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -298,6 +298,10 @@ macro (CMAKE_BUILD_UTILITIES)
add_subdirectory(Utilities/KWIML)
endif()
+ set(CMAKE_LIBRHASH_LIBRARIES cmlibrhash)
+ add_subdirectory(Utilities/cmlibrhash)
+ CMAKE_SET_TARGET_FOLDER(cmlibrhash "Utilities/3rdParty")
+
#---------------------------------------------------------------------
# Build zlib library for Curl, CMake, and CTest.
set(CMAKE_ZLIB_HEADER "cm_zlib.h")