summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Neundorf <neundorf@kde.org>2007-08-15 13:43:01 (GMT)
committerAlexander Neundorf <neundorf@kde.org>2007-08-15 13:43:01 (GMT)
commit58b0e317847994fdce6371605161ddac70a02eb3 (patch)
tree697f134434647f27997f4f5ef3939c39d6045ea1 /CMakeLists.txt
parentbdeb4ad21706771f911506ee39dbd920c16440c6 (diff)
downloadCMake-58b0e317847994fdce6371605161ddac70a02eb3.zip
CMake-58b0e317847994fdce6371605161ddac70a02eb3.tar.gz
CMake-58b0e317847994fdce6371605161ddac70a02eb3.tar.bz2
COMP: ccmake requires ncurses, according to Berk and since it doesn't build
on NetBSD where there are separate curses and ncurses libraries, and where the curses library is found, which doesn't work for ccmake while the existing ncurses library would work. With this change it should be possible to test whether the found curses lib provides ncurses functionality. Alex
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index be426c6..3a2ce35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -317,6 +317,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
#---------------------------------------------------------------------
# Use curses?
IF (UNIX)
+ SET(CURSES_NEED_NCURSES TRUE)
FIND_PACKAGE(Curses QUIET)
IF (CURSES_LIBRARY)
OPTION(BUILD_CursesDialog "Build the CMake Curses Dialog ccmake" ON)