summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-10 15:34:36 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-10 15:34:36 (GMT)
commit6c79c96265e43416fbc8130e701830389ae6c01a (patch)
tree8380af51a36bac12e81e574f1ab63b7d178f07cb /CMakeLists.txt
parent9d823f78479b19a739c3bb9037a0f72f3a65535c (diff)
downloadCMake-6c79c96265e43416fbc8130e701830389ae6c01a.zip
CMake-6c79c96265e43416fbc8130e701830389ae6c01a.tar.gz
CMake-6c79c96265e43416fbc8130e701830389ae6c01a.tar.bz2
Test 'install' target of CMake itself
We create option CMake_TEST_INSTALL to enable a new CMake.Install test. It tests running the "make install" target to install CMake itself into a test directory. We enable the option by default for dashboard builds.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fcb3174..ec31808 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -366,6 +366,10 @@ MARK_AS_ADVANCED(CMAKE_DATA_DIR CMAKE_DOC_DIR CMAKE_MAN_DIR)
STRING(REGEX REPLACE "^/" "" CMake_DATA_DEST "${CMAKE_DATA_DIR}")
STRING(REGEX REPLACE "^/" "" CMake_DOC_DEST "${CMAKE_DOC_DIR}")
+IF(BUILD_TESTING)
+ INCLUDE(${CMake_SOURCE_DIR}/Tests/CMakeInstall.cmake)
+ENDIF()
+
# include special compile flags for some compilers
INCLUDE(CompileFlags.cmake)