summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2016-08-26 12:17:42 (GMT)
committerBrad King <brad.king@kitware.com>2016-08-31 13:05:15 (GMT)
commit9a53af4068fd7f7627f8af193f551c1f2b5d4ac4 (patch)
tree66dd5b93fcf5ac62bf5a61aeb2d8d0a14ba65762 /CMakeLists.txt
parent219f741128bfe1f34a97d71fa3bcdf8588d3d890 (diff)
downloadCMake-9a53af4068fd7f7627f8af193f551c1f2b5d4ac4.zip
CMake-9a53af4068fd7f7627f8af193f551c1f2b5d4ac4.tar.gz
CMake-9a53af4068fd7f7627f8af193f551c1f2b5d4ac4.tar.bz2
Do not build libuv on Cygwin
Currently libuv does not support Cygwin (see libuv issue 832) in part due to lack of pthread APIs: https://cygwin.com/cygwin-api/std-notimpl.html
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b62f6a5..9176049 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -481,6 +481,9 @@ int main(void) { return 0; }
if(NOT HAVE_CoreServices_OS_X_10_5)
set(CMAKE_USE_LIBUV 0)
endif()
+ elseif(CYGWIN)
+ # libuv does not support Cygwin
+ set(CMAKE_USE_LIBUV 0)
endif()
endif()
if(CMAKE_USE_LIBUV)