summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-12-10 15:33:42 (GMT)
committerBrad King <brad.king@kitware.com>2009-12-10 15:33:42 (GMT)
commit9d823f78479b19a739c3bb9037a0f72f3a65535c (patch)
treea0e7db5b3ef899dc92ea3cd6db10e78b77371b40 /CMakeLists.txt
parent08ac33fe6ab5d992ff06de9f96f8a87bf4c43c70 (diff)
downloadCMake-9d823f78479b19a739c3bb9037a0f72f3a65535c.zip
CMake-9d823f78479b19a739c3bb9037a0f72f3a65535c.tar.gz
CMake-9d823f78479b19a739c3bb9037a0f72f3a65535c.tar.bz2
Apply CMake test-time config to all tests
We configure an EnforceConfig.cmake script to load at CTest time. Previously we loaded it from Tests/CTestTestfile.cmake, but now we load it from the top level so it applies to all tests.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 173e923..fcb3174 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -342,6 +342,10 @@ SET(CMake_VERSION_FULL "${CMake_VERSION}.${CMake_VERSION_PATCH}")
ENABLE_TESTING()
INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+# Set up test-time configuration.
+SET_DIRECTORY_PROPERTIES(PROPERTIES
+ TEST_INCLUDE_FILE "${CMake_BINARY_DIR}/Tests/EnforceConfig.cmake")
+
# where to write the resulting executables and libraries
SET(BUILD_SHARED_LIBS OFF)
SET(EXECUTABLE_OUTPUT_PATH "" CACHE INTERNAL "No configurable exe dir.")