summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-11-17 14:55:46 (GMT)
committerBrad King <brad.king@kitware.com>2017-11-17 15:03:41 (GMT)
commitbe592b23bd737c5c3ea9c111a139d2dd81a622b9 (patch)
tree245034af0aec68c1ddc4508a43a2ecab3dcff1f2 /CMakeLists.txt
parent8e6d6337cdfa62dd5412057c6dcb6d7c23709f6e (diff)
downloadCMake-be592b23bd737c5c3ea9c111a139d2dd81a622b9.zip
CMake-be592b23bd737c5c3ea9c111a139d2dd81a622b9.tar.gz
CMake-be592b23bd737c5c3ea9c111a139d2dd81a622b9.tar.bz2
IWYU: Suppress warnings from the internal Clang
Do not obscure IWYU's report with warnings from its internal Clang. We have other testing for such warnings. Also, when compiling with a non-Clang compiler we might use warning options that IWYU's Clang does not understand, and we don't want to see warnings about that.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f14f62f..bf0c4d1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -267,7 +267,7 @@ if(CMake_RUN_IWYU)
message(FATAL_ERROR "CMake_RUN_IWYU is ON but include-what-you-use is not found!")
endif()
set(CMAKE_CXX_INCLUDE_WHAT_YOU_USE
- "${IWYU_COMMAND};-Xiwyu;--mapping_file=${CMake_SOURCE_DIR}/Utilities/IWYU/mapping.imp")
+ "${IWYU_COMMAND};-Xiwyu;--mapping_file=${CMake_SOURCE_DIR}/Utilities/IWYU/mapping.imp;-w")
endif()