summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2017-08-21 12:46:51 (GMT)
committerKitware Robot <kwrobot@kitware.com>2017-08-21 12:48:24 (GMT)
commitc1f3eb9f2d628b2911aa17f65012fab0befc4b87 (patch)
treeb5949a7285295a8ae4faa53acaf583221d6edf21 /CMakeLists.txt
parenta1b84ac2a6eec367a8a56f4a0f811e78f5d60fab (diff)
parentfd4fd9a276126a1b1044d57a064c3b8201a91a33 (diff)
downloadCMake-c1f3eb9f2d628b2911aa17f65012fab0befc4b87.zip
CMake-c1f3eb9f2d628b2911aa17f65012fab0befc4b87.tar.gz
CMake-c1f3eb9f2d628b2911aa17f65012fab0befc4b87.tar.bz2
Merge topic 'require-c++11'
fd4fd9a2 Require C++11 to build CMake itself Acked-by: Kitware Robot <kwrobot@kitware.com> Merge-request: !1132
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 30b6da9..67c4cdc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,10 @@ if(NOT CMake_TEST_EXTERNAL_CMAKE)
# check for available C++ features
include(${CMake_SOURCE_DIR}/Source/Checks/cm_cxx_features.cmake)
+
+ if(NOT CMake_HAVE_CXX_UNIQUE_PTR)
+ message(FATAL_ERROR "The C++ compiler does not support C++11 (e.g. std::unique_ptr).")
+ endif()
endif()
# set the internal encoding of CMake to UTF-8