summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKen Martin <ken.martin@kitware.com>2008-03-01 20:20:35 (GMT)
committerKen Martin <ken.martin@kitware.com>2008-03-01 20:20:35 (GMT)
commitd49ef18f8a9ebe4e512d67d3fb88958c655beb69 (patch)
treea40a7a4649f9a7137579c6c22be29846f97d72c3 /CMakeLists.txt
parent32ca01bef0fe4218319d9c9fd02ea11336f5e134 (diff)
downloadCMake-d49ef18f8a9ebe4e512d67d3fb88958c655beb69.zip
CMake-d49ef18f8a9ebe4e512d67d3fb88958c655beb69.tar.gz
CMake-d49ef18f8a9ebe4e512d67d3fb88958c655beb69.tar.bz2
ENH: add first cut and policies still need to add the doc support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2f9a655..ac6b835 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,9 +134,7 @@ ENDMACRO(CMAKE_TEST_FOR_MFC)
# for testing. Simply to improve readability of the main script.
#-----------------------------------------------------------------------
MACRO(CMAKE_SETUP_TESTING)
- IF (NOT DART_ROOT)
- SET(MAKEPROGRAM ${CMAKE_MAKE_PROGRAM})
- ENDIF (NOT DART_ROOT)
+ SET(MAKEPROGRAM ${CMAKE_MAKE_PROGRAM})
IF(BUILD_TESTING)
SET(CMAKE_TEST_GENERATOR "" CACHE STRING
@@ -190,11 +188,6 @@ MACRO(CMAKE_SETUP_TESTING)
${CMake_BINARY_DIR}/CTestCustom.cmake @ONLY)
CONFIGURE_FILE(${CMake_SOURCE_DIR}/CTestCustom.ctest.in
${CMake_BINARY_DIR}/CTestCustom.ctest @ONLY)
- IF(BUILD_TESTING AND DART_ROOT)
- CONFIGURE_FILE(${CMake_SOURCE_DIR}/CMakeLogo.gif
- ${CMake_BINARY_DIR}/Testing/HTML/TestingResults/Icons/Logo.gif COPYONLY)
- ENDIF(BUILD_TESTING AND DART_ROOT)
- MARK_AS_ADVANCED(DART_ROOT)
MARK_AS_ADVANCED(CURL_TESTING)
ENDMACRO(CMAKE_SETUP_TESTING)
@@ -365,7 +358,7 @@ SET(CMake_VERSION_FULL "${CMake_VERSION}.${CMake_VERSION_PATCH}")
# Include the standard Dart testing module
ENABLE_TESTING()
-INCLUDE (${CMAKE_ROOT}/Modules/Dart.cmake)
+INCLUDE (${CMAKE_ROOT}/Modules/CTest.cmake)
# where to write the resulting executables and libraries
SET(BUILD_SHARED_LIBS OFF)