summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2015-08-24 14:58:42 (GMT)
committerBrad King <brad.king@kitware.com>2015-08-27 17:35:13 (GMT)
commit92b835ec9d17b190b13da93702f0eb416b665a48 (patch)
treedfa13d914d79b889f5aef2f645b5a539b7d48c91 /CMakeLists.txt
parent2370a99400c6450606e25562386cf40bc9c41f38 (diff)
downloadCMake-92b835ec9d17b190b13da93702f0eb416b665a48.zip
CMake-92b835ec9d17b190b13da93702f0eb416b665a48.tar.gz
CMake-92b835ec9d17b190b13da93702f0eb416b665a48.tar.bz2
Simplify condition for using rpcrt4 library on Windows
Drop the CMAKE_BUILD_ON_VISUAL_STUDIO variable and hard-code the condition at its only use.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36244dd..5e13a7e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -144,17 +144,6 @@ macro(CMAKE_HANDLE_SYSTEM_LIBRARIES)
endmacro()
-
-
-
-if(NOT CMake_TEST_EXTERNAL_CMAKE)
- set(CMAKE_BUILD_ON_VISUAL_STUDIO 0)
- if(WIN32 AND NOT UNIX AND NOT MINGW)
- set(CMAKE_BUILD_ON_VISUAL_STUDIO 1)
- endif()
-endif()
-
-
#-----------------------------------------------------------------------
# a macro to determine the generator and ctest executable to use
# for testing. Simply to improve readability of the main script.