summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2006-03-02 00:00:08 (GMT)
committerBrad King <brad.king@kitware.com>2006-03-02 00:00:08 (GMT)
commitae62f66033aa79cdbb564bc2e2579def43289c59 (patch)
tree3aacf8073b5fc478c67bae6bfef8eaf314c188d6 /CMakeLists.txt
parent8d9a997beb03e1ac668b4aaabe363f1d3d552b00 (diff)
downloadCMake-ae62f66033aa79cdbb564bc2e2579def43289c59.zip
CMake-ae62f66033aa79cdbb564bc2e2579def43289c59.tar.gz
CMake-ae62f66033aa79cdbb564bc2e2579def43289c59.tar.bz2
ENH: CMake does not need RPATHs at all for its own executables. Disable them to avoid relinking during installation.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29afb11..3c4353a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,6 +11,10 @@ SET(CMake_VERSION_FULL "${CMake_VERSION}.${CMake_VERSION_PATCH}")
SET(BUILD_SHARED_LIBS OFF)
+# The CMake executables do not need any rpath to run in the build or
+# install tree.
+SET(CMAKE_SKIP_RPATH ON CACHE INTERNAL "CMake does not need RPATHs.")
+
SET(CMAKE_DATA_DIR "/share/CMake" CACHE STRING
"Install location for data (relative to prefix).")
SET(CMAKE_DOC_DIR "/doc/CMake" CACHE STRING