summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2007-08-31 18:51:09 (GMT)
committerBrad King <brad.king@kitware.com>2007-08-31 18:51:09 (GMT)
commitb8ac3158ce9b82a967a9e582e89c1ecf00b69187 (patch)
tree072823247ef17eb9444988edda1ee9810d4b884f /CMakeLists.txt
parent27187d78be18c98ce6b77e44d49e2516d20105cd (diff)
downloadCMake-b8ac3158ce9b82a967a9e582e89c1ecf00b69187.zip
CMake-b8ac3158ce9b82a967a9e582e89c1ecf00b69187.tar.gz
CMake-b8ac3158ce9b82a967a9e582e89c1ecf00b69187.tar.bz2
ENH: Create CTestCustom.cmake instead of CTestCustom.ctest. Create the old file to include the new one for compatibility. This should prevent the long delays of CTest traversing the whole tree looking for CTestCustom.ctest files.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d32ffc2..89bbc54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -186,6 +186,8 @@ MACRO(CMAKE_SETUP_TESTING)
${CMake_BINARY_DIR}/Tests/.NoDartCoverage)
CONFIGURE_FILE(${CMake_SOURCE_DIR}/Tests/.NoDartCoverage
${CMake_BINARY_DIR}/Modules/.NoDartCoverage)
+ CONFIGURE_FILE(${CMake_SOURCE_DIR}/CTestCustom.cmake.in
+ ${CMake_BINARY_DIR}/CTestCustom.cmake @ONLY)
CONFIGURE_FILE(${CMake_SOURCE_DIR}/CTestCustom.ctest.in
${CMake_BINARY_DIR}/CTestCustom.ctest @ONLY)
IF(BUILD_TESTING AND DART_ROOT)