summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBill Hoffman <bill.hoffman@kitware.com>2010-06-11 17:48:23 (GMT)
committerBill Hoffman <bill.hoffman@kitware.com>2010-06-11 17:48:23 (GMT)
commitc74556bdfc9cf657619583a9e070aaea65a0b525 (patch)
tree09b67971b91e04dba5a44c794386a5868b1b477a /CMakeLists.txt
parentb9e3c243d476efa04479d253cfc4f76ecbdb6fe3 (diff)
downloadCMake-c74556bdfc9cf657619583a9e070aaea65a0b525.zip
CMake-c74556bdfc9cf657619583a9e070aaea65a0b525.tar.gz
CMake-c74556bdfc9cf657619583a9e070aaea65a0b525.tar.bz2
Make sure libarchive uses cmzlib and not the system libz if found.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69b45a4..ff31dd0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -271,6 +271,7 @@ MACRO (CMAKE_BUILD_UTILITIES)
SET(HAVE_ZLIB_H 1)
SET(ZLIB_INCLUDE_DIR ${CMAKE_ZLIB_INCLUDES})
SET(ZLIB_LIBRARIES ${CMAKE_ZLIB_LIBRARIES})
+ SET(ZLIB_LIBRARY ${CMAKE_ZLIB_LIBRARIES})
SET(BUILD_ARCHIVE_WITHIN_CMAKE TRUE)
ADD_DEFINITIONS(-DLIBARCHIVE_STATIC)
ADD_SUBDIRECTORY(Utilities/cmlibarchive)