summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2014-04-03 19:20:58 (GMT)
committerBrad King <brad.king@kitware.com>2014-04-03 19:20:58 (GMT)
commite2b02823e7986e7df59907b307480acad5ec6562 (patch)
tree10c310c595778398d96384e54cc85136dd57d0bf /CMakeLists.txt
parent8088332178a9fb082dd387beae9b1f262615a228 (diff)
downloadCMake-e2b02823e7986e7df59907b307480acad5ec6562.zip
CMake-e2b02823e7986e7df59907b307480acad5ec6562.tar.gz
CMake-e2b02823e7986e7df59907b307480acad5ec6562.tar.bz2
Update libarchive configuration within CMake
Hard-code libarchive build options to the way CMake needs them. Set them as internal cache entries so users do not see them when building CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0793d0..5e4cd15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -321,6 +321,12 @@ macro (CMAKE_BUILD_UTILITIES)
add_definitions(-DLIBARCHIVE_STATIC)
set(ENABLE_NETTLE OFF CACHE INTERNAL "Enable use of Nettle")
set(ENABLE_OPENSSL ${CMAKE_USE_OPENSSL} CACHE INTERNAL "Enable use of OpenSSL")
+ set(ENABLE_LZMA OFF CACHE INTERNAL "Enable the use of the system found LZMA library if found")
+ set(ENABLE_ZLIB ON CACHE INTERNAL "Enable the use of the system found ZLIB library if found")
+ set(ENABLE_BZip2 ON CACHE INTERNAL "Enable the use of the system found BZip2 library if found")
+ set(ENABLE_EXPAT OFF CACHE INTERNAL "Enable the use of the system found EXPAT library if found")
+ set(ENABLE_PCREPOSIX OFF CACHE INTERNAL "Enable the use of the system found PCREPOSIX library if found")
+ set(ENABLE_LibGCC OFF CACHE INTERNAL "Enable the use of the system found LibGCC library if found")
set(ENABLE_XATTR OFF CACHE INTERNAL "Enable extended attribute support")
set(ENABLE_ACL OFF CACHE INTERNAL "Enable ACL support")
set(ENABLE_ICONV OFF CACHE INTERNAL "Enable iconv support")