summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2019-08-22 19:21:06 (GMT)
committerBrad King <brad.king@kitware.com>2019-08-23 15:12:07 (GMT)
commited294c1664cafe573c813f2a95ebec3159e0d21e (patch)
treeb345410fd29d1693a90837d7ea8fd59b1f96e161 /CMakeLists.txt
parent4b8a864d52fa7501af915b3f94dfbd55fe9065b8 (diff)
downloadCMake-ed294c1664cafe573c813f2a95ebec3159e0d21e.zip
CMake-ed294c1664cafe573c813f2a95ebec3159e0d21e.tar.gz
CMake-ed294c1664cafe573c813f2a95ebec3159e0d21e.tar.bz2
Add option to skip CMake tests that need network access
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3daebee..d6e7278 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -677,7 +677,7 @@ endif()
# to a cdash4simpletest database. In these cases, the CDash dashboards
# should be run first.
#
-if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x")
+if("x${CMAKE_TESTS_CDASH_SERVER}" STREQUAL "x" AND NOT CMake_TEST_NO_NETWORK)
set(CMAKE_TESTS_CDASH_SERVER "http://open.cdash.org")
endif()