summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Upstream <kwrobot@kitware.com>2017-01-16 13:53:56 (GMT)
committerBrad King <brad.king@kitware.com>2017-01-16 19:06:28 (GMT)
commit219c7bdcb16cd1dfe2e72befa4334c5b8147e1d7 (patch)
treeaa42dc456d8441fe824c444feb3b114aee960f8c /CMakeLists.txt
parenta9ea66bd66db0f0ad9b0b59d617739ad6a04cebf (diff)
downloadCMake-219c7bdcb16cd1dfe2e72befa4334c5b8147e1d7.zip
CMake-219c7bdcb16cd1dfe2e72befa4334c5b8147e1d7.tar.gz
CMake-219c7bdcb16cd1dfe2e72befa4334c5b8147e1d7.tar.bz2
KWSys 2017-01-16 (a423d829)
Code extracted from: https://gitlab.kitware.com/utils/kwsys.git at commit a423d82989a4b89fa7d17f3dd5215684e902208e (master). Upstream Shortlog ----------------- Ben Boeckel (1): 45db0937 SystemTools: use PathExists where appropriate Brad King (1): e08eee61 SystemTools: Fix conversion warning in test case Eric Berge (1): 687fcd79 Add -lsocket for libcmsys.a build on SunOS Gregor Jasny (1): 0541ce21 SystemTools: Fix off-by-one in GetLineFromStream with size limit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9eb3b2d..d4fe8a7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -818,6 +818,9 @@ IF(KWSYS_C_SRCS OR KWSYS_CXX_SRCS)
# for symbol lookup using dladdr
TARGET_LINK_LIBRARIES(${KWSYS_NAMESPACE} ${CMAKE_DL_LIBS})
ENDIF()
+ IF (CMAKE_SYSTEM_NAME STREQUAL "SunOS")
+ TARGET_LINK_LIBRARIES(${KWSYS_NAMESPACE} socket)
+ ENDIF()
ENDIF()
ENDIF()