summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKWSys Robot <kwrobot@kitware.com>2014-07-02 14:57:17 (GMT)
committerBrad King <brad.king@kitware.com>2014-07-07 13:04:19 (GMT)
commit3d127627f8e28d97ecc44515e274b3780ae3f4b9 (patch)
tree4c1cd35ad2f054bf041265162e49db23cdc38b6a /CMakeLists.txt
parented52685dd7ea5c54e7a5e6caa789293d76f10b15 (diff)
downloadCMake-3d127627f8e28d97ecc44515e274b3780ae3f4b9.zip
CMake-3d127627f8e28d97ecc44515e274b3780ae3f4b9.tar.gz
CMake-3d127627f8e28d97ecc44515e274b3780ae3f4b9.tar.bz2
KWSys 2014-07-02 (c2a329ce)
Extract upstream KWSys using the following shell commands. $ git archive --prefix=upstream-kwsys/ c2a329ce | tar x $ git shortlog --no-merges --abbrev=8 --format='%h %s' c282e64f..c2a329ce Chuck Atkins (3): e4bba930 Directory: Make sure the /* suffix uses correct slashes 97817ce7 SystemTools: Refactor test file and directory locations 8f991ab0 SystemTools: Use extended paths on Windows for > 256 length Clinton Stimpson (1): c2a329ce Encoding: Fixes uses of stat() on Windows to work with unicode. Change-Id: I8e3aa1ba66ce80900cb25a692287495b911dcbd0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e6a226..8ca4360 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1171,10 +1171,9 @@ IF(KWSYS_STANDALONE OR CMake_SOURCE_DIR)
ADD_EXECUTABLE(${KWSYS_NAMESPACE}TestsCxx ${KWSYS_CXX_TEST_SRCS})
SET_PROPERTY(TARGET ${KWSYS_NAMESPACE}TestsCxx PROPERTY LABELS ${KWSYS_LABELS_EXE})
TARGET_LINK_LIBRARIES(${KWSYS_NAMESPACE}TestsCxx ${KWSYS_NAMESPACE})
- SET(TEST_SYSTEMTOOLS_BIN_FILE
- "${CMAKE_CURRENT_SOURCE_DIR}/testSystemTools.bin")
- SET(TEST_SYSTEMTOOLS_SRC_FILE
- "${CMAKE_CURRENT_SOURCE_DIR}/testSystemTools.cxx")
+
+ SET(TEST_SYSTEMTOOLS_SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}")
+ SET(TEST_SYSTEMTOOLS_BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}")
CONFIGURE_FILE(
${PROJECT_SOURCE_DIR}/testSystemTools.h.in
${PROJECT_BINARY_DIR}/testSystemTools.h)