summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2013-10-07 18:06:04 (GMT)
committerBrad King <brad.king@kitware.com>2013-10-15 14:46:55 (GMT)
commit09be0bb0494dcf35f80f74f442e05e6b39736e73 (patch)
tree027d3dff2b06805ddfd93d74d2b9a942f76c060b /CMakeLists.txt
parente49efe9150a492fe9cf9a0b72af61558e9aed689 (diff)
downloadCMake-09be0bb0494dcf35f80f74f442e05e6b39736e73.zip
CMake-09be0bb0494dcf35f80f74f442e05e6b39736e73.tar.gz
CMake-09be0bb0494dcf35f80f74f442e05e6b39736e73.tar.bz2
Set IDE folder for CMake 'documentation' target only if it exists
The documentation target will be come optional, so do not reference it when it does not exist.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e36daee..eb515d7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -573,7 +573,9 @@ if(BUILD_TESTING)
CMAKE_SET_TARGET_FOLDER(CMakeLibTests "Tests")
endif()
CMAKE_SET_TARGET_FOLDER(cmw9xcom "Utilities/Win9xCompat")
-CMAKE_SET_TARGET_FOLDER(documentation "Documentation")
+if(TARGET documentation)
+ CMAKE_SET_TARGET_FOLDER(documentation "Documentation")
+endif()
# add a test
add_test(SystemInformationNew "${CMAKE_CMAKE_COMMAND}"