summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrad King <brad.king@kitware.com>2009-07-31 12:27:36 (GMT)
committerBrad King <brad.king@kitware.com>2009-07-31 12:27:36 (GMT)
commit36bb624907cd2eec30c8bbfe4787e29685b80947 (patch)
tree192996737bce258d5ace2c077c18156d4411a33a /CMakeLists.txt
parent121df27fa207a233677fbdc1a0ab738593cf280c (diff)
downloadCMake-36bb624907cd2eec30c8bbfe4787e29685b80947.zip
CMake-36bb624907cd2eec30c8bbfe4787e29685b80947.tar.gz
CMake-36bb624907cd2eec30c8bbfe4787e29685b80947.tar.bz2
Fix installation when built by CMake 2.4
CMake 2.4 generates old-style cmake_install.cmake code including calls to the file(INSTALL) command with the COMPONENTS argument. We need to set CMAKE_INSTALL_SELF_2_4 for the whole install tree to prevent the command from complaining in this special case. Previously this was needed only in the QtDialog directory, but now it is needed in the entire tree.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d753cad..9f76a8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,6 +9,12 @@ MARK_AS_ADVANCED(CMAKE_BACKWARDS_COMPATIBILITY)
# Allow empty endif() and such with CMake 2.4.
SET(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS 1)
+IF(NOT ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION} GREATER 2.4)
+ # Since the built CMake will install itself instead of the
+ # generating CMake, tell it that the install rules were generated
+ # by CMake 2.4.
+ INSTALL(CODE "SET(CMAKE_INSTALL_SELF_2_4 1)")
+ENDIF()
#-----------------------------------------------------------------------
# a macro to deal with system libraries, implemented as a macro